Author Topic: Oil pump on TS won't stay up  (Read 3690 times)

0 Members and 1 Guest are viewing this topic.

Offline ste

  • Senior Member
  • ***
  • Join Date: Sep 2004
  • Posts: 195
  • Location: Oamaru, New Zealand
Oil pump on TS won't stay up
« on: 27 Aug 2016 at 05:36 »
I'm having problems with the hand oil pump on the TS project. It refuses to stay up, simply returning immediately after it is pulled up.
It has two new cups from the club, it does actually pump oil that can be seen in the bowl, and the non return little disc has been checked.
We started with oil recommended by Penrite, but it was so thick nothing happened. Drained that and put SAE 30 in, same brand and at least it gets to the motor now.
Any ideas please?

Stephen

Offline eddie

  • Master Member
  • ****
  • Join Date: Mar 2006
  • Posts: 1656
  • Location: Hampshire, UK
Re: Oil pump on TS won't stay up
« Reply #1 on: 27 Aug 2016 at 06:31 »
Stephen,
       If the non return valve works, check out the position of the port in the side of the pump body - it should be below the valve. If a different bottom pump fitting has been used, the oil may be escaping back through the port without actually going through the non return valve.

  Regards,
                Eddie.

Offline ste

  • Senior Member
  • ***
  • Join Date: Sep 2004
  • Posts: 195
  • Location: Oamaru, New Zealand
Re: Oil pump on TS won't stay up
« Reply #2 on: 28 Aug 2016 at 04:51 »
Thanks Eddie, any chance you'd have a photo of the bottom section so we know what it should look like please?
Stephen

Offline cardan

  • Master Member
  • ****
  • Join Date: Jul 2007
  • Posts: 1192
  • Location: Adelaide, South Australia
    • Leon's Vintage Motorcycle Page

Offline ste

  • Senior Member
  • ***
  • Join Date: Sep 2004
  • Posts: 195
  • Location: Oamaru, New Zealand
Re: Oil pump on TS won't stay up
« Reply #4 on: 28 Aug 2016 at 08:34 »
Many thanks guys, looks like I'm missing the lower cup. Onto it now.
Stephen

Offline ste

  • Senior Member
  • ***
  • Join Date: Sep 2004
  • Posts: 195
  • Location: Oamaru, New Zealand
Re: Oil pump on TS won't stay up
« Reply #5 on: 30 Aug 2016 at 07:06 »
Last question: I put two new leather washers in the hand pump, should it be the same leather washer in the lower section too?
Some say we should use rubber ones.
Stephen

Offline Chris

  • Master Member
  • ****
  • Join Date: Jun 2004
  • Posts: 507
  • Location: Kent, UK.
Re: Oil pump on TS won't stay up
« Reply #6 on: 30 Aug 2016 at 08:12 »
Hi Stephen
Yes! the washer in the base of the oil pump is identical to the two in the plunger except it needs a larger hole in the centre. It is this item that seals the holes in the base of the body of the oil pump when pressure is applied to the oil from the spring loaded plunger thus preventing the oil simply returning to the oil tank. Elesewhere on this forum, apart from the dimensioned drawings to enable manufacture of all parts of the system there is also a detailed description of exactly how the oiling system works. Chris.

Offline ste

  • Senior Member
  • ***
  • Join Date: Sep 2004
  • Posts: 195
  • Location: Oamaru, New Zealand
Re: Oil pump on TS won't stay up
« Reply #7 on: 30 Aug 2016 at 08:54 »
Many thanks Chris