Author Topic: Message attachment problem  (Read 2325 times)

0 Members and 1 Guest are viewing this topic.

Offline Douglas52

  • Full Member
  • **
  • Join Date: Sep 2008
  • Posts: 37
  • Location: Dunedin, New Zealand
Message attachment problem
« on: 08 Sep 2014 at 00:20 »
Hi
Been trying unsuccessfully to post a message with photo attached.
Says there is a problem with the attachment and to contact the administrator.
I virus checked the attachment; appears OK.
If you have my post submissions, could you post the last one and delete the first two, please.
Alternatively if the problem is "mine", let me know the details so I can fix it.
Cheers
Steve


Offline Dave

  • Administrator
  • ****
  • Join Date: Mar 2004
  • Posts: 3236
  • Location: Australia
Re: Message attachment problem
« Reply #1 on: 08 Sep 2014 at 05:25 »
Steve,

I believe Doug sent you a PM.

However, could you post below some information about the type and size of the file you wish to attach please?

To attach a file to a post, it currently needs to be one of these file types - doc, docx, xlsx, xls, gif, bmp, tiff, psd, jpg, mpg, pdf, png, txt, zip, html, mp3, mp4 - and be less than 4000KB in size.

If your file type is not included in the above, we may be able to add it for you.

Quote
If you have my post submissions, could you post the last one and delete the first two, please.

The latest post you have recorded in the database is your post in Restored OB/24-25 600cc OHV Douglas for sale on 27th August.

It sounds like you were entering a new message today and the attachment error has prevented the post from being saved. Unfortunately, you may have to retype the message.

Dave


Corrected typo 9th August
« Last Edit: 08 Sep 2014 at 18:46 by Dave »

Offline Dave

  • Administrator
  • ****
  • Join Date: Mar 2004
  • Posts: 3236
  • Location: Australia
Re: Message attachment problem
« Reply #2 on: 08 Sep 2014 at 20:10 »
Steve,

Doug copied me on his troubleshooting tests and provided the link to the original image file on Dropbox.

When Doug tried to attach your file to a post, he received the error message:

Quote
"Your attachment has failed security checks and cannot be uploaded. Please consult forum administrator"

This message indicated the problem area and possible solution.

When JPEG images are attached to a post, the forum software does some security checks looking for potentially malicious code contained within the metadata for the image.

Your file does not contain any malicious metadata. However it does contain the information that it was taken with an iPhone 4S and the exact GPS co-ordinates of where it was taken. It's likely that something in that string of characters in the metadata was mistaken as possible malicious code.

So we have now enabled a feature in the forum software that should overcome this problem. When it detects possible suspicious code, it will remove the metadata completely and just attach the image. We have tested this with your original file and it now posts successfully. The only disadvantage of this feature is that processing an attachment might taken fractionally longer.

So if you would like to go ahead and try posting your message again, it should work OK.

Dave
   

Offline Douglas52

  • Full Member
  • **
  • Join Date: Sep 2008
  • Posts: 37
  • Location: Dunedin, New Zealand
Re: Message attachment problem
« Reply #3 on: 08 Sep 2014 at 22:34 »
Posted fine this time.
Must have inadvertently activated the coordinate tagging on my phone.
Thanks for your help.
Steve

 

motorcycle