Douglasmotorcycles.net

General => Douglas Motorcycles - General Discussion => Topic started by: FN on 21 Jun 2021 at 15:09

Title: BTH magneto on Aero, short losses of power
Post by: FN on 21 Jun 2021 at 15:09
I am stumbling a couple of weeks with short losses of engine power. It starts well, works most of the time, and gets  power loss for parts of a second mostly with intermediate rpm. The magneto works on the lath ok. I makes continous sparks (on test plugs with 5mm gap) starting from 200 rpm (400 rpm engine) to 2000rpm. I aquired an extra magneto and put it on the bike, which behaves quite similar on the lath. The problems on the bike are gone. But this magneto got a low mass wheel. Now the question:

BTH uses a slip ring, which has a very low gradient for the points lever in comparison to Bosch. Swinging of the slip ring or the armature may detoriate the shortening of the points and loss of energy there. 
Does somebody know on mechanical problems regarding swinging of components on the magneto and its power train?
Title: Re: BTH magneto on Aero, short losses of power
Post by: Hamwic on 24 Jun 2021 at 12:47
I would suspect worn armature bearings, or slackness in them when the magneto is hot. This may have been caused by the paper magneto insulators failing. The fully open points gap on a BTH is usually .012", and this should be the same on both cams, and obviously the ramp starts should be 180 degrees apart. The cam should be a just-sliding fit in the end housing and not rattle about, as this will cause ignition scatter between the cylinders.

The low rise on the cam ramp was to offset points bounce at higher rpm, so if the points springs are weak, or one is broken perhaps, then the points will not be under control. The spring may be going into resonance at a particular rpm, and the moving point may then "float" and not make proper contact.

Another source of mechanical trouble can be binding of the moving point on its post, though by now I would have thought that this was less likely and excessive wear could be an issue.

It might be instructive to run the magneto on the bench in low ambient light conditions and see if the contact points are arcing. This would suggest a failing capacitor. After that a measurement of the secondary winding resistance might indicate that the winding is failing, or is already open-circuit. Early BTH magnetos don't really like having the armature removed for inspection or work without being re-magnetised afterwards, but a competent magneto restorer should be able to do that for you.

Either way it seems that an overhaul is overdue for this one!

Cheers for now
Doug